summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 16:11:43 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 16:45:23 +0200
commit4e19f232564148cb085e7f367f79c44e6a9c2f56 (patch)
tree7925b4c4519288b4686b95e6da64351a0af27a3e /dev-ros/rospy_tutorials
parentapp-text/sword-modules: add last-rite replacements to the list (diff)
downloadgentoo-4e19f232564148cb085e7f367f79c44e6a9c2f56.tar.gz
gentoo-4e19f232564148cb085e7f367f79c44e6a9c2f56.tar.bz2
gentoo-4e19f232564148cb085e7f367f79c44e6a9c2f56.zip
dev-ros/rospy_tutorials: set proper search path for tests
Closes: https://bugs.gentoo.org/624782 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rospy_tutorials')
-rw-r--r--dev-ros/rospy_tutorials/rospy_tutorials-0.10.1.ebuild5
-rw-r--r--dev-ros/rospy_tutorials/rospy_tutorials-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-ros/rospy_tutorials/rospy_tutorials-0.10.1.ebuild b/dev-ros/rospy_tutorials/rospy_tutorials-0.10.1.ebuild
index 21a4b9e1fc2f..9977f2feee70 100644
--- a/dev-ros/rospy_tutorials/rospy_tutorials-0.10.1.ebuild
+++ b/dev-ros/rospy_tutorials/rospy_tutorials-0.10.1.ebuild
@@ -20,3 +20,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-ros/rostest[${PYTHON_SINGLE_USEDEP}] )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}
diff --git a/dev-ros/rospy_tutorials/rospy_tutorials-9999.ebuild b/dev-ros/rospy_tutorials/rospy_tutorials-9999.ebuild
index 21a4b9e1fc2f..9977f2feee70 100644
--- a/dev-ros/rospy_tutorials/rospy_tutorials-9999.ebuild
+++ b/dev-ros/rospy_tutorials/rospy_tutorials-9999.ebuild
@@ -20,3 +20,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-ros/rostest[${PYTHON_SINGLE_USEDEP}] )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}