summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-11 18:08:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-11 18:15:57 +0200
commit3a38425ec3e6c6e1679fb135fa100cc738fb1eff (patch)
tree172fb56f333c3956e3fe119b8e71ee341642b283 /dev-ros/rosserial_python/rosserial_python-9999.ebuild
parentdev-ros/rosserial_msgs: Initial import. Ebuild by me. (diff)
downloadgentoo-3a38425ec3e6c6e1679fb135fa100cc738fb1eff.tar.gz
gentoo-3a38425ec3e6c6e1679fb135fa100cc738fb1eff.tar.bz2
gentoo-3a38425ec3e6c6e1679fb135fa100cc738fb1eff.zip
dev-ros/rosserial_python: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/rosserial_python/rosserial_python-9999.ebuild')
-rw-r--r--dev-ros/rosserial_python/rosserial_python-9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosserial_python/rosserial_python-9999.ebuild b/dev-ros/rosserial_python/rosserial_python-9999.ebuild
new file mode 100644
index 000000000000..21d484d242b5
--- /dev/null
+++ b/dev-ros/rosserial_python/rosserial_python-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="A Python-based implementation of the ROS serial protocol"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosserial_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"