summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-14 11:50:13 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-14 12:38:20 +0100
commit76584c6c69d22ff982be77b041b06c2a5f883def (patch)
tree41d3183bc0ded1ef01f0e46df8be2efdfc3efc30 /dev-ros/rosservice/rosservice-1.11.17.ebuild
parentdev-ros/rosparam: Bump to 1.11.17. (diff)
downloadgentoo-76584c6c69d22ff982be77b041b06c2a5f883def.tar.gz
gentoo-76584c6c69d22ff982be77b041b06c2a5f883def.tar.bz2
gentoo-76584c6c69d22ff982be77b041b06c2a5f883def.zip
dev-ros/rosservice: Bump to 1.11.17.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosservice/rosservice-1.11.17.ebuild')
-rw-r--r--dev-ros/rosservice/rosservice-1.11.17.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosservice/rosservice-1.11.17.ebuild b/dev-ros/rosservice/rosservice-1.11.17.ebuild
new file mode 100644
index 000000000000..05fb1e6f2599
--- /dev/null
+++ b/dev-ros/rosservice/rosservice-1.11.17.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for listing and querying ROS Services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"