summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-01-28 10:44:03 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-28 13:54:32 +0100
commit086982f8dbfae925539637d79d000d4698a8d693 (patch)
treea25900df09f7d55f257f39eed88640d6aa2600a2 /dev-ros/rostime/rostime-0.6.8.ebuild
parentdev-ros/cpp_common: Bump to 0.6.8. (diff)
downloadgentoo-086982f8dbfae925539637d79d000d4698a8d693.tar.gz
gentoo-086982f8dbfae925539637d79d000d4698a8d693.tar.bz2
gentoo-086982f8dbfae925539637d79d000d4698a8d693.zip
dev-ros/rostime: Bump to 0.6.8.
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'dev-ros/rostime/rostime-0.6.8.ebuild')
-rw-r--r--dev-ros/rostime/rostime-0.6.8.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rostime/rostime-0.6.8.ebuild b/dev-ros/rostime/rostime-0.6.8.ebuild
new file mode 100644
index 000000000000..6d97b2f7c4f5
--- /dev/null
+++ b/dev-ros/rostime/rostime-0.6.8.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Time and Duration implementations for C++ libraries"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/cpp_common
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"