summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-15 11:32:57 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-15 13:25:34 +0200
commited91b51c2f4ffedd03230f1a88e4317317dd3488 (patch)
tree0b1642de402517a05e1699a96255e02127e245e8 /dev-ros/rostopic/rostopic-1.11.15.ebuild
parentdev-ros/rostest: Bump to 1.11.15. (diff)
downloadgentoo-ed91b51c2f4ffedd03230f1a88e4317317dd3488.tar.gz
gentoo-ed91b51c2f4ffedd03230f1a88e4317317dd3488.tar.bz2
gentoo-ed91b51c2f4ffedd03230f1a88e4317317dd3488.zip
dev-ros/rostopic: Bump to 1.11.15.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/rostopic/rostopic-1.11.15.ebuild')
-rw-r--r--dev-ros/rostopic/rostopic-1.11.15.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/rostopic/rostopic-1.11.15.ebuild b/dev-ros/rostopic/rostopic-1.11.15.ebuild
new file mode 100644
index 000000000000..c3438a04756b
--- /dev/null
+++ b/dev-ros/rostopic/rostopic-1.11.15.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS Topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"