summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-20 14:50:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-20 14:50:13 +0200
commita20a08df0a6b78fd134baf2905cb4c776e8393db (patch)
tree54d19d71ea52c7ebf7049d965d9bec2de5043d2f /dev-ros/rostopic/rostopic-1.12.4.ebuild
parentdev-ros/rostest: Bump to 1.12.4. (diff)
downloadgentoo-a20a08df0a6b78fd134baf2905cb4c776e8393db.tar.gz
gentoo-a20a08df0a6b78fd134baf2905cb4c776e8393db.tar.bz2
gentoo-a20a08df0a6b78fd134baf2905cb4c776e8393db.zip
dev-ros/rostopic: Bump to 1.12.4.
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ros/rostopic/rostopic-1.12.4.ebuild')
-rw-r--r--dev-ros/rostopic/rostopic-1.12.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/rostopic/rostopic-1.12.4.ebuild b/dev-ros/rostopic/rostopic-1.12.4.ebuild
new file mode 100644
index 000000000000..b03d11e04d0e
--- /dev/null
+++ b/dev-ros/rostopic/rostopic-1.12.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS Topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"