summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-03 13:03:46 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-03 13:21:49 +0200
commit44dc34ecf44afac87dd6d09fc1e0b9a705be6270 (patch)
treeee4e94e1001a45a2fb735937a60b613ff839369e /dev-ros/roswtf/roswtf-1.14.2.ebuild
parentdev-ros/xmlrpcpp: Bump to 1.14.2. (diff)
downloadgentoo-44dc34ecf44afac87dd6d09fc1e0b9a705be6270.tar.gz
gentoo-44dc34ecf44afac87dd6d09fc1e0b9a705be6270.tar.bz2
gentoo-44dc34ecf44afac87dd6d09fc1e0b9a705be6270.zip
dev-ros/roswtf: Bump to 1.14.2.
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-ros/roswtf/roswtf-1.14.2.ebuild')
-rw-r--r--dev-ros/roswtf/roswtf-1.14.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/roswtf/roswtf-1.14.2.ebuild b/dev-ros/roswtf/roswtf-1.14.2.ebuild
new file mode 100644
index 000000000000..396feee7b7a8
--- /dev/null
+++ b/dev-ros/roswtf/roswtf-1.14.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for diagnosing issues with a running ROS system"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-util/rosdep[${PYTHON_USEDEP}]
+ dev-util/rosinstall[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"