summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-07 15:53:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-07 17:48:48 +0200
commit6f2d6cf784cf2bd9fb8665a259191279281b5e1f (patch)
tree9d1ff794d6c1da582d54afee06266dfcf10fa7fd /dev-ros/roswtf/roswtf-1.14.3.ebuild
parentdev-ros/xmlrpcpp: Bump to 1.14.3. (diff)
downloadgentoo-6f2d6cf784cf2bd9fb8665a259191279281b5e1f.tar.gz
gentoo-6f2d6cf784cf2bd9fb8665a259191279281b5e1f.tar.bz2
gentoo-6f2d6cf784cf2bd9fb8665a259191279281b5e1f.zip
dev-ros/roswtf: Bump to 1.14.3.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-ros/roswtf/roswtf-1.14.3.ebuild')
-rw-r--r--dev-ros/roswtf/roswtf-1.14.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/roswtf/roswtf-1.14.3.ebuild b/dev-ros/roswtf/roswtf-1.14.3.ebuild
new file mode 100644
index 000000000000..396feee7b7a8
--- /dev/null
+++ b/dev-ros/roswtf/roswtf-1.14.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for diagnosing issues with a running ROS system"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-util/rosdep[${PYTHON_USEDEP}]
+ dev-util/rosinstall[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"