summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-10 10:53:25 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-10 11:34:51 +0100
commitedc5dd3fc7cb7668d4833961a5fe6854a79d0a66 (patch)
treeb01d2e214e7160b553b0c47e10e226cf49006526 /dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.3.13.ebuild
parentdev-ros/rqt_bag: Bump to 0.3.13. (diff)
downloadgentoo-edc5dd3fc7cb7668d4833961a5fe6854a79d0a66.tar.gz
gentoo-edc5dd3fc7cb7668d4833961a5fe6854a79d0a66.tar.bz2
gentoo-edc5dd3fc7cb7668d4833961a5fe6854a79d0a66.zip
dev-ros/rqt_bag_plugins: Bump to 0.3.13.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.3.13.ebuild')
-rw-r--r--dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.3.13.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.3.13.ebuild b/dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.3.13.ebuild
new file mode 100644
index 000000000000..a07401e9fe63
--- /dev/null
+++ b/dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.3.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for displaying and replaying ROS bag files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_bag[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"