summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-17 12:06:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-17 12:21:31 +0200
commit094259498fddaf5c16b909e6a971eb71619ec500 (patch)
treec24cffbf2f2b631d8e4ed886a77a8d063a2f500f /dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.1.ebuild
parentdev-ros/rqt_bag: Bump to 0.4.1. (diff)
downloadgentoo-094259498fddaf5c16b909e6a971eb71619ec500.tar.gz
gentoo-094259498fddaf5c16b909e6a971eb71619ec500.tar.bz2
gentoo-094259498fddaf5c16b909e6a971eb71619ec500.zip
dev-ros/rqt_bag_plugins: Bump to 0.4.1.
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.1.ebuild')
-rw-r--r--dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.1.ebuild b/dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.1.ebuild
new file mode 100644
index 000000000000..068890bcd835
--- /dev/null
+++ b/dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for displaying and replaying ROS bag files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_bag[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"