summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-10 09:13:31 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-10 09:51:17 +0100
commitce40b22b2329ee83bf6331d121d26ff529c85d70 (patch)
treef6700cbfa7e14be94ef9a825e4b6c952e7662f33 /dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.11.ebuild
parentdev-ros/rosconsole_bridge: bump to 0.5.1 (diff)
downloadgentoo-ce40b22b2329ee83bf6331d121d26ff529c85d70.tar.gz
gentoo-ce40b22b2329ee83bf6331d121d26ff529c85d70.tar.bz2
gentoo-ce40b22b2329ee83bf6331d121d26ff529c85d70.zip
dev-ros/rqt_bag_plugins: bump to 0.4.11
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.11.ebuild')
-rw-r--r--dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.11.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.11.ebuild b/dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.11.ebuild
new file mode 100644
index 000000000000..48735760362d
--- /dev/null
+++ b/dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.11.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_bag"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for displaying and replaying ROS bag files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_bag[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"