summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-03-27 08:37:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-03-27 08:40:59 +0200
commitc058bc8362763463de4e8d9fd577b2585e1efeff (patch)
tree855f862d2a811226869a2650c39b2a34643f22f8 /dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.12.ebuild
parentdev-ros/rqt_bag_plugins: Remove old (diff)
downloadgentoo-c058bc8362763463de4e8d9fd577b2585e1efeff.tar.gz
gentoo-c058bc8362763463de4e8d9fd577b2585e1efeff.tar.bz2
gentoo-c058bc8362763463de4e8d9fd577b2585e1efeff.zip
dev-ros/rqt_bag_plugins: bump to 0.4.12
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.12.ebuild')
-rw-r--r--dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.12.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.12.ebuild b/dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.12.ebuild
new file mode 100644
index 000000000000..0f850d2d8e5f
--- /dev/null
+++ b/dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_bag"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for displaying and replaying ROS bag files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_bag[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"