summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 17:13:17 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:01:47 +0200
commit7a0d9453a426eb3017cdd094d73f393238d61d70 (patch)
tree3b0ce3197080bf5bde3901b266ea744bd686b1ae /dev-ros/rqt_dep/rqt_dep-0.4.10.ebuild
parentdev-ros/rqt_graph: Remove old (diff)
downloadgentoo-7a0d9453a426eb3017cdd094d73f393238d61d70.tar.gz
gentoo-7a0d9453a426eb3017cdd094d73f393238d61d70.tar.bz2
gentoo-7a0d9453a426eb3017cdd094d73f393238d61d70.zip
dev-ros/rqt_dep: bump to 0.4.10
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_dep/rqt_dep-0.4.10.ebuild')
-rw-r--r--dev-ros/rqt_dep/rqt_dep-0.4.10.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rqt_dep/rqt_dep-0.4.10.ebuild b/dev-ros/rqt_dep/rqt_dep-0.4.10.ebuild
new file mode 100644
index 000000000000..ce968836e024
--- /dev/null
+++ b/dev-ros/rqt_dep/rqt_dep-0.4.10.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_dep"
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS dependency graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rqt_graph[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"