summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 07:37:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 08:40:04 +0200
commite57f3395bcfb8705125f5811e4ffca18df81b67a (patch)
treeb36c995897187d104c9a4f0688a939ee588f22a3 /dev-ros/rqt_dep/rqt_dep-0.4.8.ebuild
parentdev-ros/rqt_dep: remove old (diff)
downloadgentoo-e57f3395bcfb8705125f5811e4ffca18df81b67a.tar.gz
gentoo-e57f3395bcfb8705125f5811e4ffca18df81b67a.tar.bz2
gentoo-e57f3395bcfb8705125f5811e4ffca18df81b67a.zip
dev-ros/rqt_dep: bump to 0.4.8 and update to separate repo
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rqt_dep/rqt_dep-0.4.8.ebuild')
-rw-r--r--dev-ros/rqt_dep/rqt_dep-0.4.8.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rqt_dep/rqt_dep-0.4.8.ebuild b/dev-ros/rqt_dep/rqt_dep-0.4.8.ebuild
new file mode 100644
index 000000000000..da5568842166
--- /dev/null
+++ b/dev-ros/rqt_dep/rqt_dep-0.4.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_dep"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS dependency graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rqt_graph[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"