summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:18:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:18:39 +0200
commit231eb79831ba0c4b060f9e2577a3f587c2ec1f64 (patch)
treedd97c6a86ebcdd7b6e2ab7451aebb1bf084cc75e /dev-ros/rqt_dep/rqt_dep-9999.ebuild
parentdev-ros/rqt_console: Initial import. Ebuild by me. (diff)
downloadgentoo-231eb79831ba0c4b060f9e2577a3f587c2ec1f64.tar.gz
gentoo-231eb79831ba0c4b060f9e2577a3f587c2ec1f64.tar.bz2
gentoo-231eb79831ba0c4b060f9e2577a3f587c2ec1f64.zip
dev-ros/rqt_dep: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_dep/rqt_dep-9999.ebuild')
-rw-r--r--dev-ros/rqt_dep/rqt_dep-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/rqt_dep/rqt_dep-9999.ebuild b/dev-ros/rqt_dep/rqt_dep-9999.ebuild
new file mode 100644
index 000000000000..42f648f98506
--- /dev/null
+++ b/dev-ros/rqt_dep/rqt_dep-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS dependency graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rqt_graph[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"