summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-17 09:07:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-17 09:07:01 +0200
commit88e87fc526762652e2805fe4dfa7b24d70a67e57 (patch)
tree5577dd99411408b1a5c680134117162228a869f3 /dev-ros/rqt_graph/rqt_graph-0.4.10.ebuild
parentdev-ros/rqt_graph: Remove old (diff)
downloadgentoo-88e87fc526762652e2805fe4dfa7b24d70a67e57.tar.gz
gentoo-88e87fc526762652e2805fe4dfa7b24d70a67e57.tar.bz2
gentoo-88e87fc526762652e2805fe4dfa7b24d70a67e57.zip
dev-ros/rqt_graph: bump to 0.4.10
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-ros/rqt_graph/rqt_graph-0.4.10.ebuild')
-rw-r--r--dev-ros/rqt_graph/rqt_graph-0.4.10.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/rqt_graph/rqt_graph-0.4.10.ebuild b/dev-ros/rqt_graph/rqt_graph-0.4.10.ebuild
new file mode 100644
index 000000000000..a40a5c1b0a81
--- /dev/null
+++ b/dev-ros/rqt_graph/rqt_graph-0.4.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_graph"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS computation graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosservice[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"