summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 16:21:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:01:39 +0200
commitaf8da0b95af320540a0c79bca5d071de93f5abfc (patch)
tree604ec84c1f1512a7387b441468dd3d4667ced6ba /dev-ros/rqt_gui_py/rqt_gui_py-0.5.2.ebuild
parentdev-ros/rqt_gui_cpp: Bump to 0.5.2. (diff)
downloadgentoo-af8da0b95af320540a0c79bca5d071de93f5abfc.tar.gz
gentoo-af8da0b95af320540a0c79bca5d071de93f5abfc.tar.bz2
gentoo-af8da0b95af320540a0c79bca5d071de93f5abfc.zip
dev-ros/rqt_gui_py: Bump to 0.5.2.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_gui_py/rqt_gui_py-0.5.2.ebuild')
-rw-r--r--dev-ros/rqt_gui_py/rqt_gui_py-0.5.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rqt_gui_py/rqt_gui_py-0.5.2.ebuild b/dev-ros/rqt_gui_py/rqt_gui_py-0.5.2.ebuild
new file mode 100644
index 000000000000..9f317ef2e8cc
--- /dev/null
+++ b/dev-ros/rqt_gui_py/rqt_gui_py-0.5.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Enables GUI plugins to use the Python client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+ >=dev-ros/rqt_gui-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"