summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 16:21:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:01:39 +0200
commit271faf5ea16a1ca388b7533529a1c4e70876a41b (patch)
treecab46599ae0fc8416be9f51932881a2ac198579b /dev-ros/rqt_py_common
parentdev-ros/rqt_gui_py: Bump to 0.5.2. (diff)
downloadgentoo-271faf5ea16a1ca388b7533529a1c4e70876a41b.tar.gz
gentoo-271faf5ea16a1ca388b7533529a1c4e70876a41b.tar.bz2
gentoo-271faf5ea16a1ca388b7533529a1c4e70876a41b.zip
dev-ros/rqt_py_common: Bump to 0.5.2.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_py_common')
-rw-r--r--dev-ros/rqt_py_common/Manifest1
-rw-r--r--dev-ros/rqt_py_common/rqt_py_common-0.5.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/rqt_py_common/Manifest b/dev-ros/rqt_py_common/Manifest
index 81d5744640e4..9507b4171672 100644
--- a/dev-ros/rqt_py_common/Manifest
+++ b/dev-ros/rqt_py_common/Manifest
@@ -1,2 +1,3 @@
DIST rqt-0.5.0.tar.gz 120992 BLAKE2B 645d53ec7070fc5a40760bedc556328e26a16dea7b2990ad0512bc372cb346d545dbea42689b4c39039f17abc4920d5059e5b9a25ac7b77f8b5e5cc02100c5ac SHA512 5c91fe9bce5a7cb0cdc54b42667488d30c33bd57afd30cc8f2047b91b7aa7b8afd936090bfc76be5dbc8c6497623c1be4340e061503f5a65bc94faaad810597e
+DIST rqt-0.5.2.tar.gz 121619 BLAKE2B a065501ee6f78b3e2867aa9a6fc416b70472a3dcd3bf447ab7c07941284add7fdaffafa4bc370ce73b777b9616544a6650bb94c30fb61bed8ce6381a2d88b5cd SHA512 09093e80daefd530b36c1ef90a350c0c5fa7ba4211b779da38c230df445170e766a737cfadec29997f81968c454daec2ffc2b6cf236e41daa21d9536f498fc17
DIST rqt_common_plugins-0.4.7.tar.gz 246977 BLAKE2B 5efebfa64dcc587822e558b5527a2ef2e33adc8adcb45800876e278be5ccdacbaef93b0f9dfbb7b98972fd5cffb4fcddee80e9522a4135a736d744765c2490ed SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7
diff --git a/dev-ros/rqt_py_common/rqt_py_common-0.5.2.ebuild b/dev-ros/rqt_py_common/rqt_py_common-0.5.2.ebuild
new file mode 100644
index 000000000000..3f96b22ee793
--- /dev/null
+++ b/dev-ros/rqt_py_common/rqt_py_common-0.5.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common functionality for rqt plugins written in Python"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"