summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-20 15:08:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-20 15:08:44 +0200
commit67fd592324438c3b86293c4b94d4a3ecf76e65dc (patch)
treebc7819dc47123b795aeed2bd22dd8aee3df336df /dev-ros/rqt_py_console/rqt_py_console-0.4.2.ebuild
parentdev-ros/rqt_py_common: Bump to 0.4.2. (diff)
downloadgentoo-67fd592324438c3b86293c4b94d4a3ecf76e65dc.tar.gz
gentoo-67fd592324438c3b86293c4b94d4a3ecf76e65dc.tar.bz2
gentoo-67fd592324438c3b86293c4b94d4a3ecf76e65dc.zip
dev-ros/rqt_py_console: Bump to 0.4.2.
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ros/rqt_py_console/rqt_py_console-0.4.2.ebuild')
-rw-r--r--dev-ros/rqt_py_console/rqt_py_console-0.4.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/rqt_py_console/rqt_py_console-0.4.2.ebuild b/dev-ros/rqt_py_console/rqt_py_console-0.4.2.ebuild
new file mode 100644
index 000000000000..5a1fa13f7ac8
--- /dev/null
+++ b/dev-ros/rqt_py_console/rqt_py_console-0.4.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python GUI plugin providing an interactive Python console"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"