summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:24:55 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:24:55 +0200
commit4c17303b8d251eda52d378264bef193adf7a7c38 (patch)
treebfb4eb6541ba6a107f2689503f986a721ac2a3f1 /dev-ros/rqt_reconfigure/rqt_reconfigure-9999.ebuild
parentdev-ros/rqt_py_console: Initial import. Ebuild by me. (diff)
downloadgentoo-4c17303b8d251eda52d378264bef193adf7a7c38.tar.gz
gentoo-4c17303b8d251eda52d378264bef193adf7a7c38.tar.bz2
gentoo-4c17303b8d251eda52d378264bef193adf7a7c38.zip
dev-ros/rqt_reconfigure: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_reconfigure/rqt_reconfigure-9999.ebuild')
-rw-r--r--dev-ros/rqt_reconfigure/rqt_reconfigure-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/rqt_reconfigure/rqt_reconfigure-9999.ebuild b/dev-ros/rqt_reconfigure/rqt_reconfigure-9999.ebuild
new file mode 100644
index 000000000000..0674f5237388
--- /dev/null
+++ b/dev-ros/rqt_reconfigure/rqt_reconfigure-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Provides the way to view and edit the parameters that are accessible via dynamic_reconfigure"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_console[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"