summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:35:23 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:35:23 +0200
commit5a943fff993901b24d85943240fa6eac13ef7ba9 (patch)
treec858ebbaf5552650f5e2350271fab64f18254c2e /dev-ros/rqt_robot_steering/rqt_robot_steering-9999.ebuild
parentdev-ros/rqt_robot_monitor: Initial import. Ebuild by me. (diff)
downloadgentoo-5a943fff993901b24d85943240fa6eac13ef7ba9.tar.gz
gentoo-5a943fff993901b24d85943240fa6eac13ef7ba9.tar.bz2
gentoo-5a943fff993901b24d85943240fa6eac13ef7ba9.zip
dev-ros/rqt_robot_steering: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_robot_steering/rqt_robot_steering-9999.ebuild')
-rw-r--r--dev-ros/rqt_robot_steering/rqt_robot_steering-9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rqt_robot_steering/rqt_robot_steering-9999.ebuild b/dev-ros/rqt_robot_steering/rqt_robot_steering-9999.ebuild
new file mode 100644
index 000000000000..9e34fafd50af
--- /dev/null
+++ b/dev-ros/rqt_robot_steering/rqt_robot_steering-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for steering a robot using Twist messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"