summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-20 15:29:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-20 15:29:10 +0200
commit08a9b47ea1b579aa32e798e6b05116a4ac6bb946 (patch)
tree97ea3f01fd6c3db901bbcbd51ca1d0dd94b772a5 /dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.4.ebuild
parentdev-ros/rqt_robot_steering: Bump to 0.5.4. (diff)
downloadgentoo-08a9b47ea1b579aa32e798e6b05116a4ac6bb946.tar.gz
gentoo-08a9b47ea1b579aa32e798e6b05116a4ac6bb946.tar.bz2
gentoo-08a9b47ea1b579aa32e798e6b05116a4ac6bb946.zip
dev-ros/rqt_runtime_monitor: Bump to 0.5.4.
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.4.ebuild')
-rw-r--r--dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.4.ebuild b/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.4.ebuild
new file mode 100644
index 000000000000..72748d8ea4b9
--- /dev/null
+++ b/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin viewing DiagnosticsArray messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"