summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-11 09:21:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-11 09:37:48 +0200
commit2ddf9032608c421a43e4f37fc2a1bea4b6e26441 (patch)
treea386abcf1b73b25cdcae0cf32dee1aacd3485a4e /dev-ros/rqt_srv/rqt_srv-0.4.0.ebuild
parentdev-ros/rqt_shell: Bump to 0.4.0. (diff)
downloadgentoo-2ddf9032608c421a43e4f37fc2a1bea4b6e26441.tar.gz
gentoo-2ddf9032608c421a43e4f37fc2a1bea4b6e26441.tar.bz2
gentoo-2ddf9032608c421a43e4f37fc2a1bea4b6e26441.zip
dev-ros/rqt_srv: Bump to 0.4.0.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/rqt_srv/rqt_srv-0.4.0.ebuild')
-rw-r--r--dev-ros/rqt_srv/rqt_srv-0.4.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rqt_srv/rqt_srv-0.4.0.ebuild b/dev-ros/rqt_srv/rqt_srv-0.4.0.ebuild
new file mode 100644
index 000000000000..fa68ee697b6f
--- /dev/null
+++ b/dev-ros/rqt_srv/rqt_srv-0.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for introspecting available ROS message types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_msg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"