summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-28 10:37:16 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-29 12:05:38 +0200
commitb5abc75601a11ce64742071d17cf1902ae980b3b (patch)
tree0bfa77918165ac12d8e6e7425812f52077a22b45 /dev-ros/rqt_tf_tree/rqt_tf_tree-0.5.8.ebuild
parentdev-ml/bin-prot: bump to 0.9.1 (diff)
downloadgentoo-b5abc75601a11ce64742071d17cf1902ae980b3b.tar.gz
gentoo-b5abc75601a11ce64742071d17cf1902ae980b3b.tar.bz2
gentoo-b5abc75601a11ce64742071d17cf1902ae980b3b.zip
dev-ros/rqt_tf_tree: bump to 0.5.8
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ros/rqt_tf_tree/rqt_tf_tree-0.5.8.ebuild')
-rw-r--r--dev-ros/rqt_tf_tree/rqt_tf_tree-0.5.8.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/rqt_tf_tree/rqt_tf_tree-0.5.8.ebuild b/dev-ros/rqt_tf_tree/rqt_tf_tree-0.5.8.ebuild
new file mode 100644
index 000000000000..acd62217748c
--- /dev/null
+++ b/dev-ros/rqt_tf_tree/rqt_tf_tree-0.5.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_tf_tree"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS TF frame tree"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_graph[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"