summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:37:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:37:26 +0200
commit082ae5baef7625e3927f85079643ab3c5d6ca365 (patch)
tree3d7979ca8521a883574c288302f18ed3f750af2e /dev-ros/rqt_tf_tree/rqt_tf_tree-9999.ebuild
parentdev-ros/rqt_rviz: Initial import. Ebuild by me. (diff)
downloadgentoo-082ae5baef7625e3927f85079643ab3c5d6ca365.tar.gz
gentoo-082ae5baef7625e3927f85079643ab3c5d6ca365.tar.bz2
gentoo-082ae5baef7625e3927f85079643ab3c5d6ca365.zip
dev-ros/rqt_tf_tree: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_tf_tree/rqt_tf_tree-9999.ebuild')
-rw-r--r--dev-ros/rqt_tf_tree/rqt_tf_tree-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/rqt_tf_tree/rqt_tf_tree-9999.ebuild b/dev-ros/rqt_tf_tree/rqt_tf_tree-9999.ebuild
new file mode 100644
index 000000000000..7447465d5a7a
--- /dev/null
+++ b/dev-ros/rqt_tf_tree/rqt_tf_tree-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS TF frame tree"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_graph[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"