summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-20 15:09:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-20 15:09:04 +0200
commitdd90a651218414e74d93e8a5cce8abdc5bf078c8 (patch)
tree0bdd2f20982d51206d16726831d9ac65b1069a31 /dev-ros/rqt_top/rqt_top-0.4.2.ebuild
parentdev-ros/rqt_srv: Bump to 0.4.2. (diff)
downloadgentoo-dd90a651218414e74d93e8a5cce8abdc5bf078c8.tar.gz
gentoo-dd90a651218414e74d93e8a5cce8abdc5bf078c8.tar.bz2
gentoo-dd90a651218414e74d93e8a5cce8abdc5bf078c8.zip
dev-ros/rqt_top: Bump to 0.4.2.
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ros/rqt_top/rqt_top-0.4.2.ebuild')
-rw-r--r--dev-ros/rqt_top/rqt_top-0.4.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rqt_top/rqt_top-0.4.2.ebuild b/dev-ros/rqt_top/rqt_top-0.4.2.ebuild
new file mode 100644
index 000000000000..90c4135009d4
--- /dev/null
+++ b/dev-ros/rqt_top/rqt_top-0.4.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="RQT plugin for monitoring ROS processes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"