summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 08:07:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 08:40:12 +0200
commitd7be2c7ca13aa18425ed9460a67d18bd89a01e82 (patch)
tree428d6e81c954a1531dd966a979d9f6c54fda1443 /dev-ros/rqt_top/rqt_top-0.4.8.ebuild
parentdev-ros/rqt_top: remove old (diff)
downloadgentoo-d7be2c7ca13aa18425ed9460a67d18bd89a01e82.tar.gz
gentoo-d7be2c7ca13aa18425ed9460a67d18bd89a01e82.tar.bz2
gentoo-d7be2c7ca13aa18425ed9460a67d18bd89a01e82.zip
dev-ros/rqt_top: bump to 0.4.8 and update to split repo
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rqt_top/rqt_top-0.4.8.ebuild')
-rw-r--r--dev-ros/rqt_top/rqt_top-0.4.8.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rqt_top/rqt_top-0.4.8.ebuild b/dev-ros/rqt_top/rqt_top-0.4.8.ebuild
new file mode 100644
index 000000000000..820eade78b5b
--- /dev/null
+++ b/dev-ros/rqt_top/rqt_top-0.4.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_top"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="RQT plugin for monitoring ROS processes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"