summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-28 08:37:14 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-28 12:26:46 +0100
commite5c2792451316a8c30e68ee0fc6c9176f7a37df3 (patch)
tree1b147befc4d02046f22b3676f1a7fc832fb1f078 /dev-ros/rqt_web/rqt_web-0.4.6.ebuild
parentdev-ros/rqt_topic: Bump to 0.4.6. (diff)
downloadgentoo-e5c2792451316a8c30e68ee0fc6c9176f7a37df3.tar.gz
gentoo-e5c2792451316a8c30e68ee0fc6c9176f7a37df3.tar.bz2
gentoo-e5c2792451316a8c30e68ee0fc6c9176f7a37df3.zip
dev-ros/rqt_web: Bump to 0.4.6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rqt_web/rqt_web-0.4.6.ebuild')
-rw-r--r--dev-ros/rqt_web/rqt_web-0.4.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rqt_web/rqt_web-0.4.6.ebuild b/dev-ros/rqt_web/rqt_web-0.4.6.ebuild
new file mode 100644
index 000000000000..aabf8cb330c2
--- /dev/null
+++ b/dev-ros/rqt_web/rqt_web-0.4.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Simple web content viewer for rqt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"