summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-26 19:13:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-26 19:29:30 +0200
commitd2d92d2f948a7e9a5179ba82fcd50970a81856fd (patch)
treec20298617f9d4502fcadb4614817d1f0ada1d92c /dev-ros/self_test/self_test-1.9.0.ebuild
parentdev-ros/diagnostic_updater: Bump to 1.9.0. (diff)
downloadgentoo-d2d92d2f948a7e9a5179ba82fcd50970a81856fd.tar.gz
gentoo-d2d92d2f948a7e9a5179ba82fcd50970a81856fd.tar.bz2
gentoo-d2d92d2f948a7e9a5179ba82fcd50970a81856fd.zip
dev-ros/self_test: Bump to 1.9.0.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/self_test/self_test-1.9.0.ebuild')
-rw-r--r--dev-ros/self_test/self_test-1.9.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/self_test/self_test-1.9.0.ebuild b/dev-ros/self_test/self_test-1.9.0.ebuild
new file mode 100644
index 000000000000..a3bbb51a443c
--- /dev/null
+++ b/dev-ros/self_test/self_test-1.9.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Robot self-test node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs
+ dev-ros/diagnostic_updater
+ dev-ros/roscpp
+ dev-ros/rostest
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest )"