summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 11:33:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 11:39:23 +0200
commitc05ae937f17aa7046d560a52a48c1422ec82ed74 (patch)
treeb84d1b6eb70a9ef04c90b8849feb4e5dd25e51d1 /dev-ros/sensor_msgs/sensor_msgs-9999.ebuild
parentdev-ros/nav_msgs: Initial import. Ebuild by me. (diff)
downloadgentoo-c05ae937f17aa7046d560a52a48c1422ec82ed74.tar.gz
gentoo-c05ae937f17aa7046d560a52a48c1422ec82ed74.tar.bz2
gentoo-c05ae937f17aa7046d560a52a48c1422ec82ed74.zip
dev-ros/sensor_msgs: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/sensor_msgs/sensor_msgs-9999.ebuild')
-rw-r--r--dev-ros/sensor_msgs/sensor_msgs-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/sensor_msgs/sensor_msgs-9999.ebuild b/dev-ros/sensor_msgs/sensor_msgs-9999.ebuild
new file mode 100644
index 000000000000..8949babd495d
--- /dev/null
+++ b/dev-ros/sensor_msgs/sensor_msgs-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/common_msgs"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages for commonly used sensors, including cameras and scanning laser rangefinders"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+RDEPEND="${RDEPEND}
+ dev-libs/boost"