summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-02 09:56:08 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-02 09:56:08 +0100
commit0d168f929fa3ab3ce9c751cbd270d40baad7234b (patch)
tree486d12b00cd54ff82745c1da065b8e5f1915b4d9 /dev-ros/shape_tools/shape_tools-9999.ebuild
parentdev-ros/depthimage_to_laserscan: Initial import. Ebuild by me. (diff)
downloadgentoo-0d168f929fa3ab3ce9c751cbd270d40baad7234b.tar.gz
gentoo-0d168f929fa3ab3ce9c751cbd270d40baad7234b.tar.bz2
gentoo-0d168f929fa3ab3ce9c751cbd270d40baad7234b.zip
dev-ros/shape_tools: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/shape_tools/shape_tools-9999.ebuild')
-rw-r--r--dev-ros/shape_tools/shape_tools-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/shape_tools/shape_tools-9999.ebuild b/dev-ros/shape_tools/shape_tools-9999.ebuild
new file mode 100644
index 000000000000..55a402976188
--- /dev/null
+++ b/dev-ros/shape_tools/shape_tools-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-planning/shape_tools"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for operating on shape messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/shape_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
+ -i CMakeLists.txt \
+ || die
+}