summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-07 17:38:48 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-07 17:52:23 +0200
commitbcc157901b4e73a38340ad10c34d6cf4ab6b6ae0 (patch)
treed0a2a5344e2ca38a211ce8b10bbc6bf853f8a3b3 /dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.4.ebuild
parentdev-ros/diagnostic_aggregator: add := dep on pluginlib (diff)
downloadgentoo-bcc157901b4e73a38340ad10c34d6cf4ab6b6ae0.tar.gz
gentoo-bcc157901b4e73a38340ad10c34d6cf4ab6b6ae0.tar.bz2
gentoo-bcc157901b4e73a38340ad10c34d6cf4ab6b6ae0.zip
dev-ros/test_diagnostic_aggregator: fix tests
Closes: https://bugs.gentoo.org/624784 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.4.ebuild')
-rw-r--r--dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.4.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.4.ebuild b/dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.4.ebuild
index 5fe90378f6ec..fcaf935a3f4e 100644
--- a/dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.4.ebuild
+++ b/dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.4.ebuild
@@ -23,3 +23,9 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/gcc6.patch" )
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ export CATKIN_PREFIX_PATH="${BUILD_DIR}/devel/:${CATKIN_PREFIX_PATH}"
+ ros-catkin_src_test
+}