summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-14 12:05:23 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-14 12:05:23 +0100
commit77f8184a32dd86c5e0a0aea70e3f5912aa2d20cf (patch)
tree072b641dc7cc2fc35721896aef63c2aba57574f4 /dev-ros/test_rosbag/test_rosbag-1.11.16.ebuild
parentdev-ros/rospy: Bump to 1.11.16. (diff)
downloadgentoo-77f8184a32dd86c5e0a0aea70e3f5912aa2d20cf.tar.gz
gentoo-77f8184a32dd86c5e0a0aea70e3f5912aa2d20cf.tar.bz2
gentoo-77f8184a32dd86c5e0a0aea70e3f5912aa2d20cf.zip
dev-ros/test_rosbag: Bump to 1.11.16.
Package-Manager: portage-2.2.24 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rosbag/test_rosbag-1.11.16.ebuild')
-rw-r--r--dev-ros/test_rosbag/test_rosbag-1.11.16.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/test_rosbag/test_rosbag-1.11.16.ebuild b/dev-ros/test_rosbag/test_rosbag-1.11.16.ebuild
new file mode 100644
index 000000000000..fd134828883f
--- /dev/null
+++ b/dev-ros/test_rosbag/test_rosbag-1.11.16.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosbag"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_generation
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-ros/topic_tools[${PYTHON_USEDEP}]
+ dev-ros/xmlrpcpp
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/boost[threads]
+ app-arch/bzip2
+ dev-ros/rosout
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ )
+"