summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-03 13:05:14 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-03 13:21:51 +0200
commit98e778376fd477d8b067cecab6b82e9a0b2647bb (patch)
tree59681f2a8f28688cc3ae83328e5656c9d68b3dd3 /dev-ros/test_rosbag/test_rosbag-1.14.2.ebuild
parentdev-ros/rospy: Bump to 1.14.2. (diff)
downloadgentoo-98e778376fd477d8b067cecab6b82e9a0b2647bb.tar.gz
gentoo-98e778376fd477d8b067cecab6b82e9a0b2647bb.tar.bz2
gentoo-98e778376fd477d8b067cecab6b82e9a0b2647bb.zip
dev-ros/test_rosbag: Bump to 1.14.2.
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-ros/test_rosbag/test_rosbag-1.14.2.ebuild')
-rw-r--r--dev-ros/test_rosbag/test_rosbag-1.14.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/test_rosbag/test_rosbag-1.14.2.ebuild b/dev-ros/test_rosbag/test_rosbag-1.14.2.ebuild
new file mode 100644
index 000000000000..e1c884997333
--- /dev/null
+++ b/dev-ros/test_rosbag/test_rosbag-1.14.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosbag"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_generation
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-ros/topic_tools[${PYTHON_USEDEP}]
+ dev-ros/xmlrpcpp
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/boost[threads]
+ app-arch/bzip2
+ dev-ros/rosout
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ )
+"