summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-20 11:56:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-20 14:43:58 +0200
commit5aba71a20527bfb1bc5919473d2b1b025523d908 (patch)
treeca152bb3aaab6585ae6e444998c36958a27e9ca2 /dev-ros/test_roscpp/test_roscpp-1.15.9.ebuild
parentdev-ros/test_rosbag_storage: Bump to 1.15.9. (diff)
downloadgentoo-5aba71a20527bfb1bc5919473d2b1b025523d908.tar.gz
gentoo-5aba71a20527bfb1bc5919473d2b1b025523d908.tar.bz2
gentoo-5aba71a20527bfb1bc5919473d2b1b025523d908.zip
dev-ros/test_roscpp: Bump to 1.15.9.
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_roscpp/test_roscpp-1.15.9.ebuild')
-rw-r--r--dev-ros/test_roscpp/test_roscpp-1.15.9.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ros/test_roscpp/test_roscpp-1.15.9.ebuild b/dev-ros/test_roscpp/test_roscpp-1.15.9.ebuild
new file mode 100644
index 000000000000..6162bbe7696c
--- /dev/null
+++ b/dev-ros/test_roscpp/test_roscpp-1.15.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for roscpp"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=[threads]
+ test? (
+ dev-cpp/gtest
+ )
+"
+REQUIRED_USE="test? ( ros_messages_cxx )"
+PATCHES=( "${FILESDIR}/tests.patch" )
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ # Sometimes high number of tests running in parallel make them fail
+ # https://bugs.gentoo.org/738620
+ ros-catkin_src_test -j 1
+}