summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 12:31:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:20:58 +0200
commiteebd52f1f6972b2be634f1e40f7119af1106bebd (patch)
treef5fd3265d5b369d72ad562458927aae06ef91952 /dev-ros/test_roscpp
parentdev-ros/test_rosbag_storage: Bump to 1.15.8. (diff)
downloadgentoo-eebd52f1f6972b2be634f1e40f7119af1106bebd.tar.gz
gentoo-eebd52f1f6972b2be634f1e40f7119af1106bebd.tar.bz2
gentoo-eebd52f1f6972b2be634f1e40f7119af1106bebd.zip
dev-ros/test_roscpp: Bump to 1.15.8.
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_roscpp')
-rw-r--r--dev-ros/test_roscpp/Manifest1
-rw-r--r--dev-ros/test_roscpp/test_roscpp-1.15.8.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/test_roscpp/Manifest b/dev-ros/test_roscpp/Manifest
index 5d86517495e4..adf4f2af1194 100644
--- a/dev-ros/test_roscpp/Manifest
+++ b/dev-ros/test_roscpp/Manifest
@@ -1 +1,2 @@
DIST ros_comm-1.15.7.tar.gz 1080092 BLAKE2B d5c0dd1f54eac7aa11be21bbc680f85f988cc9328382c0c675b7d5986e888be603ed82affa5f51a270974d07044debe3ecf86f5647fd59cb29e8e791a227feb9 SHA512 67dc100e8ed03a25ea228cc7d456ec2203324098f9e11c9a249299df73bfc34efc75b1221c0fb6fceb38fece627f1dc5f2c23be93c9a1c85b1075784a45ff20e
+DIST ros_comm-1.15.8.tar.gz 1080826 BLAKE2B c1a1e085225a96cf0b50309cb78e1ccdabefce1f23ee669393b7fc747537c7e39bfb6ad382b0d24e3b5507b1d0f3eaf2051a1bee90507b0e724e06a83df301a2 SHA512 b1c34ab6548400fc014eda496e5d1e1c7d134b9062a031386ac4eac3245ca83b034f74f0a189ccf9ec6933c18d6df0ae1a93d05f1526d09debf70c25aa25b6b9
diff --git a/dev-ros/test_roscpp/test_roscpp-1.15.8.ebuild b/dev-ros/test_roscpp/test_roscpp-1.15.8.ebuild
new file mode 100644
index 000000000000..d1b28ba0acaa
--- /dev/null
+++ b/dev-ros/test_roscpp/test_roscpp-1.15.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for roscpp"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=[threads]
+ test? (
+ dev-cpp/gtest
+ )
+"
+REQUIRED_USE="test? ( ros_messages_cxx )"