summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-04 11:32:14 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-04 12:05:42 +0100
commit92e3cfc69605db22e4307790be128d4edf0f6c77 (patch)
tree87e8e678da7ca4c92fc4774589e26e82d7a1acfb /dev-ros/test_rosgraph/test_rosgraph-1.13.4.ebuild
parentdev-ros/test_roscpp: Bump to 1.13.4. (diff)
downloadgentoo-92e3cfc69605db22e4307790be128d4edf0f6c77.tar.gz
gentoo-92e3cfc69605db22e4307790be128d4edf0f6c77.tar.bz2
gentoo-92e3cfc69605db22e4307790be128d4edf0f6c77.zip
dev-ros/test_rosgraph: Bump to 1.13.4.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/test_rosgraph/test_rosgraph-1.13.4.ebuild')
-rw-r--r--dev-ros/test_rosgraph/test_rosgraph-1.13.4.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/test_rosgraph/test_rosgraph-1.13.4.ebuild b/dev-ros/test_rosgraph/test_rosgraph-1.13.4.ebuild
new file mode 100644
index 000000000000..a74f6b7bd3cb
--- /dev/null
+++ b/dev-ros/test_rosgraph/test_rosgraph-1.13.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosgraph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rostest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rosgraph[${PYTHON_USEDEP}] )
+"