summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-06 18:06:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-06 18:09:03 +0200
commitcfee35024c2570bb1d29899817b5f81e44aa923a (patch)
treefa4a8a0f492864a211c1cb061601f3960b95a89f /dev-ros/test_rosgraph/test_rosgraph-1.15.8.ebuild
parentdev-ros/smach_ros: fix tests (diff)
downloadgentoo-cfee35024c2570bb1d29899817b5f81e44aa923a.tar.gz
gentoo-cfee35024c2570bb1d29899817b5f81e44aa923a.tar.bz2
gentoo-cfee35024c2570bb1d29899817b5f81e44aa923a.zip
dev-ros/test_rosgraph: fix tests
Closes: https://bugs.gentoo.org/625128 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rosgraph/test_rosgraph-1.15.8.ebuild')
-rw-r--r--dev-ros/test_rosgraph/test_rosgraph-1.15.8.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-ros/test_rosgraph/test_rosgraph-1.15.8.ebuild b/dev-ros/test_rosgraph/test_rosgraph-1.15.8.ebuild
index 17776e85e11b..71104c076e50 100644
--- a/dev-ros/test_rosgraph/test_rosgraph-1.15.8.ebuild
+++ b/dev-ros/test_rosgraph/test_rosgraph-1.15.8.ebuild
@@ -18,3 +18,8 @@ RDEPEND="dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]"
DEPEND="${RDEPEND}
test? ( dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}] )
"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}