summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-20 11:56:43 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-20 14:43:59 +0200
commitd87a2a7b909b0244e89e832e5c619c141691a8f8 (patch)
tree63da7498bf6ca831c2b8c6651ed73b56706763ce /dev-ros/test_rosgraph/test_rosgraph-1.15.9.ebuild
parentdev-ros/test_roscpp: Bump to 1.15.9. (diff)
downloadgentoo-d87a2a7b909b0244e89e832e5c619c141691a8f8.tar.gz
gentoo-d87a2a7b909b0244e89e832e5c619c141691a8f8.tar.bz2
gentoo-d87a2a7b909b0244e89e832e5c619c141691a8f8.zip
dev-ros/test_rosgraph: Bump to 1.15.9.
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rosgraph/test_rosgraph-1.15.9.ebuild')
-rw-r--r--dev-ros/test_rosgraph/test_rosgraph-1.15.9.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/test_rosgraph/test_rosgraph-1.15.9.ebuild b/dev-ros/test_rosgraph/test_rosgraph-1.15.9.ebuild
new file mode 100644
index 000000000000..71104c076e50
--- /dev/null
+++ b/dev-ros/test_rosgraph/test_rosgraph-1.15.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosgraph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}] )
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}