summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 16:13:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:29 +0200
commit19a7e9e03b195da6ca752c126a9a0b563cb92719 (patch)
treebb5d777f8fbff3c8c16740b0216f69710fb75711 /dev-ros/test_rosgraph/test_rosgraph-9999.ebuild
parentdev-ros/test_roscpp: Initial import. Ebuild by me. (diff)
downloadgentoo-19a7e9e03b195da6ca752c126a9a0b563cb92719.tar.gz
gentoo-19a7e9e03b195da6ca752c126a9a0b563cb92719.tar.bz2
gentoo-19a7e9e03b195da6ca752c126a9a0b563cb92719.zip
dev-ros/test_rosgraph: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/test_rosgraph/test_rosgraph-9999.ebuild')
-rw-r--r--dev-ros/test_rosgraph/test_rosgraph-9999.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/test_rosgraph/test_rosgraph-9999.ebuild b/dev-ros/test_rosgraph/test_rosgraph-9999.ebuild
new file mode 100644
index 000000000000..86083c9d0f86
--- /dev/null
+++ b/dev-ros/test_rosgraph/test_rosgraph-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosgraph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rostest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rosgraph[${PYTHON_USEDEP}] )
+"