summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-04 11:32:21 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-04 12:05:42 +0100
commit186506e5ac838d54117695457b108985e072215b (patch)
tree7ab094584dbcffbf21c3eafaf0bd3c8f3f76c71d /dev-ros/test_roslib_comm/test_roslib_comm-1.13.4.ebuild
parentdev-ros/test_roslaunch: Bump to 1.13.4. (diff)
downloadgentoo-186506e5ac838d54117695457b108985e072215b.tar.gz
gentoo-186506e5ac838d54117695457b108985e072215b.tar.bz2
gentoo-186506e5ac838d54117695457b108985e072215b.zip
dev-ros/test_roslib_comm: Bump to 1.13.4.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/test_roslib_comm/test_roslib_comm-1.13.4.ebuild')
-rw-r--r--dev-ros/test_roslib_comm/test_roslib_comm-1.13.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/test_roslib_comm/test_roslib_comm-1.13.4.ebuild b/dev-ros/test_roslib_comm/test_roslib_comm-1.13.4.ebuild
new file mode 100644
index 000000000000..cc727786c8e9
--- /dev/null
+++ b/dev-ros/test_roslib_comm/test_roslib_comm-1.13.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for roslib"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-ros/roslib[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] dev-ros/test_rosmaster )
+"