summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-20 11:56:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-20 14:43:59 +0200
commit63c98d88e1fc3ee84be302fb29db5ac1f9c2850b (patch)
treed440339c5f9ca1132488c47cdfaeb4a3ce627e29 /dev-ros/test_roslib_comm/test_roslib_comm-1.15.9.ebuild
parentdev-ros/test_roslaunch: Bump to 1.15.9. (diff)
downloadgentoo-63c98d88e1fc3ee84be302fb29db5ac1f9c2850b.tar.gz
gentoo-63c98d88e1fc3ee84be302fb29db5ac1f9c2850b.tar.bz2
gentoo-63c98d88e1fc3ee84be302fb29db5ac1f9c2850b.zip
dev-ros/test_roslib_comm: Bump to 1.15.9.
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_roslib_comm/test_roslib_comm-1.15.9.ebuild')
-rw-r--r--dev-ros/test_roslib_comm/test_roslib_comm-1.15.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/test_roslib_comm/test_roslib_comm-1.15.9.ebuild b/dev-ros/test_roslib_comm/test_roslib_comm-1.15.9.ebuild
new file mode 100644
index 000000000000..d53ce85e7df6
--- /dev/null
+++ b/dev-ros/test_roslib_comm/test_roslib_comm-1.15.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for roslib"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ dev-ros/test_rosmaster
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ )
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}