summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-06 12:47:24 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-06 13:12:51 +0200
commitda832dbc3e93b7b4f20b755bcab3b2234aa616aa (patch)
tree268b0ae94d41379e263efddba00a5695b09480c3 /dev-ros/test_rosmaster/test_rosmaster-1.12.2.ebuild
parentdev-ros/test_roslib_comm: Bump to 1.12.2. (diff)
downloadgentoo-da832dbc3e93b7b4f20b755bcab3b2234aa616aa.tar.gz
gentoo-da832dbc3e93b7b4f20b755bcab3b2234aa616aa.tar.bz2
gentoo-da832dbc3e93b7b4f20b755bcab3b2234aa616aa.zip
dev-ros/test_rosmaster: Bump to 1.12.2.
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-ros/test_rosmaster/test_rosmaster-1.12.2.ebuild')
-rw-r--r--dev-ros/test_rosmaster/test_rosmaster-1.12.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/test_rosmaster/test_rosmaster-1.12.2.ebuild b/dev-ros/test_rosmaster/test_rosmaster-1.12.2.ebuild
new file mode 100644
index 000000000000..0f62ead04104
--- /dev/null
+++ b/dev-ros/test_rosmaster/test_rosmaster-1.12.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosmaster"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/roslib[${PYTHON_USEDEP}] )
+"
+
+mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )
+
+src_install() {
+ ros-catkin_src_install
+ dodir /usr/share/${PN}
+ cp -a test "${ED}//usr/share/${PN}/" || die
+}