summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-30 18:12:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-30 18:43:52 +0200
commita6bc32f21f6913de2347c638ef9a64500e2eece9 (patch)
tree44b69e09f34409317da88a6299963cb5272f83a1 /dev-ros/test_rosparam/test_rosparam-1.13.1.ebuild
parentdev-ros/test_rosmaster: Bump to 1.13.1. (diff)
downloadgentoo-a6bc32f21f6913de2347c638ef9a64500e2eece9.tar.gz
gentoo-a6bc32f21f6913de2347c638ef9a64500e2eece9.tar.bz2
gentoo-a6bc32f21f6913de2347c638ef9a64500e2eece9.zip
dev-ros/test_rosparam: Bump to 1.13.1.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ros/test_rosparam/test_rosparam-1.13.1.ebuild')
-rw-r--r--dev-ros/test_rosparam/test_rosparam-1.13.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/test_rosparam/test_rosparam-1.13.1.ebuild b/dev-ros/test_rosparam/test_rosparam-1.13.1.ebuild
new file mode 100644
index 000000000000..5e1ce7075a30
--- /dev/null
+++ b/dev-ros/test_rosparam/test_rosparam-1.13.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosparam"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rosparam[${PYTHON_USEDEP}]
+ )"