summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-21 10:53:37 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-21 11:07:36 +0200
commitae9c207fa8b1f88ffa47ad86e2dffb88be7f7c74 (patch)
treedf4f5d16c3e490a0261237bbd91f3f4948949e51 /dev-ros/test_rospy/test_rospy-1.12.1.ebuild
parentdev-ros/test_rosparam: Bump to 1.12.1. (diff)
downloadgentoo-ae9c207fa8b1f88ffa47ad86e2dffb88be7f7c74.tar.gz
gentoo-ae9c207fa8b1f88ffa47ad86e2dffb88be7f7c74.tar.bz2
gentoo-ae9c207fa8b1f88ffa47ad86e2dffb88be7f7c74.zip
dev-ros/test_rospy: Bump to 1.12.1.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/test_rospy/test_rospy-1.12.1.ebuild')
-rw-r--r--dev-ros/test_rospy/test_rospy-1.12.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/test_rospy/test_rospy-1.12.1.ebuild b/dev-ros/test_rospy/test_rospy-1.12.1.ebuild
new file mode 100644
index 000000000000..174ea68dbec0
--- /dev/null
+++ b/dev-ros/test_rospy/test_rospy-1.12.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosbuild
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"