summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-08 18:29:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-08 19:30:04 +0200
commit2d1b3c21e4a89c10a37d400eb3b8a12c72bb6bbd (patch)
treeed0800009ed02e72839bf16418a6379c236b5e63 /dev-ros/test_rospy/test_rospy-1.15.7.ebuild
parentdev-ros/test_rosparam: Bump to 1.15.7. (diff)
downloadgentoo-2d1b3c21e4a89c10a37d400eb3b8a12c72bb6bbd.tar.gz
gentoo-2d1b3c21e4a89c10a37d400eb3b8a12c72bb6bbd.tar.bz2
gentoo-2d1b3c21e4a89c10a37d400eb3b8a12c72bb6bbd.zip
dev-ros/test_rospy: Bump to 1.15.7.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rospy/test_rospy-1.15.7.ebuild')
-rw-r--r--dev-ros/test_rospy/test_rospy-1.15.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/test_rospy/test_rospy-1.15.7.ebuild b/dev-ros/test_rospy/test_rospy-1.15.7.ebuild
new file mode 100644
index 000000000000..a60ab86abc52
--- /dev/null
+++ b/dev-ros/test_rospy/test_rospy-1.15.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosbuild
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"