summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-15 11:33:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-15 13:25:34 +0200
commitf36d3b3525b21adc2c4386667265164b2fb788c2 (patch)
tree942b6ad9720c8f81648f83efc98e1d229c2e9c20 /dev-ros/test_rosservice/test_rosservice-1.11.15.ebuild
parentdev-ros/test_rospy: Bump to 1.11.15. (diff)
downloadgentoo-f36d3b3525b21adc2c4386667265164b2fb788c2.tar.gz
gentoo-f36d3b3525b21adc2c4386667265164b2fb788c2.tar.bz2
gentoo-f36d3b3525b21adc2c4386667265164b2fb788c2.zip
dev-ros/test_rosservice: Bump to 1.11.15.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/test_rosservice/test_rosservice-1.11.15.ebuild')
-rw-r--r--dev-ros/test_rosservice/test_rosservice-1.11.15.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/test_rosservice/test_rosservice-1.11.15.ebuild b/dev-ros/test_rosservice/test_rosservice-1.11.15.ebuild
new file mode 100644
index 000000000000..2a35b10b96ff
--- /dev/null
+++ b/dev-ros/test_rosservice/test_rosservice-1.11.15.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"