summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-07 15:55:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-07 17:48:54 +0200
commitbd0d057c7fb14dbfbac4213321081f66dd7e7c3c (patch)
tree6285ae160b2a836ee785f5bd2b647b415be7e7ee /dev-ros/test_rosservice/test_rosservice-1.14.3.ebuild
parentdev-ros/test_rospy: Bump to 1.14.3. (diff)
downloadgentoo-bd0d057c7fb14dbfbac4213321081f66dd7e7c3c.tar.gz
gentoo-bd0d057c7fb14dbfbac4213321081f66dd7e7c3c.tar.bz2
gentoo-bd0d057c7fb14dbfbac4213321081f66dd7e7c3c.zip
dev-ros/test_rosservice: Bump to 1.14.3.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-ros/test_rosservice/test_rosservice-1.14.3.ebuild')
-rw-r--r--dev-ros/test_rosservice/test_rosservice-1.14.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/test_rosservice/test_rosservice-1.14.3.ebuild b/dev-ros/test_rosservice/test_rosservice-1.14.3.ebuild
new file mode 100644
index 000000000000..e129fbdc99eb
--- /dev/null
+++ b/dev-ros/test_rosservice/test_rosservice-1.14.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"