summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 16:35:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:32 +0200
commit2616a7beddf135a572c02677cd4ad01fb3762e27 (patch)
tree940333e861c23cb052966b73f8814c04a24f17e1 /dev-ros/test_rosservice/test_rosservice-9999.ebuild
parentdev-ros/test_rosmaster: Initial import. Ebuild by me. (diff)
downloadgentoo-2616a7beddf135a572c02677cd4ad01fb3762e27.tar.gz
gentoo-2616a7beddf135a572c02677cd4ad01fb3762e27.tar.bz2
gentoo-2616a7beddf135a572c02677cd4ad01fb3762e27.zip
dev-ros/test_rosservice: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/test_rosservice/test_rosservice-9999.ebuild')
-rw-r--r--dev-ros/test_rosservice/test_rosservice-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/test_rosservice/test_rosservice-9999.ebuild b/dev-ros/test_rosservice/test_rosservice-9999.ebuild
new file mode 100644
index 000000000000..2a35b10b96ff
--- /dev/null
+++ b/dev-ros/test_rosservice/test_rosservice-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"