summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 18:30:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 19:04:20 +0200
commit8a24dec447e546f0e3f76276f9ed4d0ddcde99db (patch)
tree8797575b505422feedb73cf112e159573fd6e766 /dev-ros/tf2_py/tf2_py-9999.ebuild
parentdev-ros/tf2: Initial import. Ebuild by me. (diff)
downloadgentoo-8a24dec447e546f0e3f76276f9ed4d0ddcde99db.tar.gz
gentoo-8a24dec447e546f0e3f76276f9ed4d0ddcde99db.tar.bz2
gentoo-8a24dec447e546f0e3f76276f9ed4d0ddcde99db.zip
dev-ros/tf2_py: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/tf2_py/tf2_py-9999.ebuild')
-rw-r--r--dev-ros/tf2_py/tf2_py-9999.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/tf2_py/tf2_py-9999.ebuild b/dev-ros/tf2_py/tf2_py-9999.ebuild
new file mode 100644
index 000000000000..aaa13254f691
--- /dev/null
+++ b/dev-ros/tf2_py/tf2_py-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry_experimental"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 python bindings"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"